Issue after issue. [SOLVED]

View previous topic View next topic Go down

Issue after issue. [SOLVED]

Post by Almanorek on Sat 08 Sep 2012, 14:27

I have spent the past twelve hours or so trying to install enough of The Sims 3 to get Dragonsire's Doctor Who mods to work. During that time I have come across a very large vat of issues, none of which I can comprehend, let alone solve.

The very first thing I tried was simply installing all the expansions I had downloaded, after the main game of course: World Adventures, Ambitions, Late Night, Generations, Pets, and Supernatural. I followed the ultimate patch guide, replacing the executables, and then trying to run the launcher for the download. I get an error, service failed to initialize, "Unable to start game service initialization failed (0x0175dcbb)" I think, okay, I must've screwed up somewhere during the installation process. I uninstall it all, reinstall it, try again, and get the same error. Some Googling tells me I should only have used Games4theworld's torrents. In my defense, I hadn't found the site until after I had picked my downloads, but, regardless, I deleted everything I had downloaded and started over.

And then I installed everything again, same problem. Uninstalled, reinstalled, exact same error, every time. I read about using CCleaner, but that didn't make a difference.

So then I thought, I'll just install these one by one and see what part is killing my installation. Before I had just run the installers and done all the cracking afterwards, but this time I intended to follow the installation instructions for each individual expansion. The first one installed fine. I couldn't update, but I supposed that wouldn't be possible until a later expansion was installed. Then came the instructions for the first expansion, World Adventures:

"2. Now open the Start menu. Type 'regedit' in the search box and press [ENTER]. Navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\Sims\The Sims 3 and double-click on 'SKU'."

I checked my registry and found that no entries had been made regarding the Sims. There was no HKEY_LOCAL_MACHINE\SOFTWARE\Sims\The Sims 3, nor was there a Electronic Arts\Sims\The Sims 3, so I thought that maybe the installer for the base game had been updated and you didn't need to edit the registry anymore, so I moved on to the patch step. Launching sims3patch.exe presented me with an installer that was completely illegible. Maybe the file got messed up at some point? Regardless, while it patched the game, I was only able to get it to do so through context clues. Then I got to the sequential patches. Upon running 'Sims3_1.2.7.00002_from_1.0.631.00002.exe' I was told that my game region wasn't correct. So I tried the TS3_1.38.151.0180xx_update.exe manual update. Upon doing that, I was right back where I started, with the service initialization error.

Now, yes, I can get the base, unpatched game to work, but I was really hoping to get more than that, especially since most people seem to get things working at one point or another. I was really hoping I could get some help here, because I'm floundering and there doesn't seem to be much I can do without someone more knowledgeable.


Last edited by Almanorek on Sat 08 Sep 2012, 16:32; edited 1 time in total

Almanorek
Beginner
Beginner

Posts : 3
Points : 1814
Reputation : 0
Join date : 2012-09-08

View user profile

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by cagil99 on Sat 08 Sep 2012, 15:00

This thread will help you... Click Here

_________________
Pills N Potions, we are overdosing. drunken
Can't stand it but I still love you.  bounce

______________________________________________________________________
My topics(click click, wont hurt Razz)
Finding out your bad .package files and speeding up your game
The Sims 3 CC "Please Make Sure Your Game Has the Latest Software Updates and Try Again" Fix
Solving Simple Lags and Making Game Faster (Changing Clothes are Faster etc)


Loop
Start playing when buffered ( Only Notify

) -
%
Smart Buffer
Estimated Time:
Donate to SmartVideo!
Global Preferences
avatar
cagil99
Posting Lord
Posting Lord

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Male Posts : 284
Points : 2283
Reputation : 31
Join date : 2012-06-24
Age : 18
Location : Cyprus

View user profile

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by Timmyboi on Sat 08 Sep 2012, 15:13

After reviewing Cagill99's link it seems everything suggested in the topic you have tryed already.

Just to note, I don't use all of the games4theworld game torrents, and I have all expansions working fine.

In the past, Admin has suggested not to use other modified installers to install the Sims, but since you re-installed with games4theworld game files, this shouldn't be a issue.

You can always follow this video to try and fix this issue:
http://www.youtube.com/watch?v=IyKMnpKHGg8

Don't change, move or modify any installion files.

Remove any mods you may have.

Get back to us if you continue to have issues.

_________________

avatar
Timmyboi
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3, Stronghold 1&2&3, Evil Genius, Swtor, Prototype 1&2, Black and White
Male Posts : 37
Points : 1927
Reputation : 0
Join date : 2012-07-14
Age : 24
Location : Sheffield, UK

View user profile http://www.tellyzone.co.uk

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by Almanorek on Sat 08 Sep 2012, 15:25

So, after reading the link posted by Cagill99, I checked my registry, and there is in fact a folder in SOFTWARE called Wow6432Node, with a Sims folder inside of it. The relevant registry entries seem to be there, and, while I'm confused as to why they're there instead of where they're instead of the root SOFTWARE folder (Because I'm running a 64-bit version of Windows?) I'll try installation again with this in mind and post the results.

Almanorek
Beginner
Beginner

Posts : 3
Points : 1814
Reputation : 0
Join date : 2012-09-08

View user profile

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by cagil99 on Sat 08 Sep 2012, 16:04

As I said in the link:

Go to Start>Run>and type regedit, a window will pop up. Then
HKEY_LOCAL_MACHINE>SOFTWARE>Wow6432Node>Sims. There should be
sims 3 folder and expansions(some of them are installed and some of them
installed and then you removed them but they have leftovers in
registry) for example: you entered the
folder I said in registry then saw sims 3, Sims 3 Late night and Sims 3
Ambitions, but you just have Sims 3 Late Night, delete the Sims 3
Ambitions folder. And try to open game again.
If you stuck with this, come to chatbox I can help you more in it.

_________________
Pills N Potions, we are overdosing. drunken
Can't stand it but I still love you.  bounce

______________________________________________________________________
My topics(click click, wont hurt Razz)
Finding out your bad .package files and speeding up your game
The Sims 3 CC "Please Make Sure Your Game Has the Latest Software Updates and Try Again" Fix
Solving Simple Lags and Making Game Faster (Changing Clothes are Faster etc)


Loop
Start playing when buffered ( Only Notify

) -
%
Smart Buffer
Estimated Time:
Donate to SmartVideo!
Global Preferences
avatar
cagil99
Posting Lord
Posting Lord

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Male Posts : 284
Points : 2283
Reputation : 31
Join date : 2012-06-24
Age : 18
Location : Cyprus

View user profile

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by Almanorek on Sat 08 Sep 2012, 16:32

Simply using HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sims\The Sims 3 as my registry folder made all the difference. Actually being able to follow every instruction to the letter probably helped. (Though I refrained from reinstalling everything for Late Night and I'm glad it didn't matter) I didn't even need the Ultimate Fix. I'm a little disappointed though, if only because my problem was easily solved and I should've been able to find that link on my own if I had looked harder. But, really, thank you. You've solved a huge headache.

Almanorek
Beginner
Beginner

Posts : 3
Points : 1814
Reputation : 0
Join date : 2012-09-08

View user profile

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by cagil99 on Sat 08 Sep 2012, 16:52

You are welcome. Happy Simming The Sims 3 plumbob The Sims Plumbob 1 Smile

_________________
Pills N Potions, we are overdosing. drunken
Can't stand it but I still love you.  bounce

______________________________________________________________________
My topics(click click, wont hurt Razz)
Finding out your bad .package files and speeding up your game
The Sims 3 CC "Please Make Sure Your Game Has the Latest Software Updates and Try Again" Fix
Solving Simple Lags and Making Game Faster (Changing Clothes are Faster etc)


Loop
Start playing when buffered ( Only Notify

) -
%
Smart Buffer
Estimated Time:
Donate to SmartVideo!
Global Preferences
avatar
cagil99
Posting Lord
Posting Lord

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Male Posts : 284
Points : 2283
Reputation : 31
Join date : 2012-06-24
Age : 18
Location : Cyprus

View user profile

Back to top Go down

Re: Issue after issue. [SOLVED]

Post by Adwomin on Sat 08 Sep 2012, 17:53

Topic closed, enjoy the game!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026351
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum