Expansion pack installer does not recognize installed base game

View previous topic View next topic Go down

Expansion pack installer does not recognize installed base game

Post by austeyre on Tue 09 Oct 2012, 07:26

I poked around a bit in the forum to find someone else who encountered this error, but I didn't see anyone. Also, for reference, I'm running Windows 7.

I installed the base game, and it worked fine (because I got impatient waiting for the expansions to download and played it for a bit as-is).
I then attempted to install a number of expansion packs without success. I tried Supernatural, Master Suite Stuff, and Diesel stuff (the only ones to have completed downloading thus far).
To be sure I hadn't screwed something up by playing the game first, I uninstalled, re-downloaded (because I'd deleted the original download files), and then reinstalled the base game (without adding the crack this time, I wanted to try without) before trying again to install the expansions with the same error.

Looks a little something like this:


austeyre
Beginner
Beginner

Windows version :
  • Windows 7

Posts : 4
Points : 1845
Reputation : 0
Join date : 2012-10-09
Age : 24
Location : Canada

View user profile http://uss-assbutt.tumblr.com

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by invalidusername on Tue 09 Oct 2012, 07:57

Did you let the game install itself in it's default spot, or somewhere else? if you chose to have it somewhere else, like on a different drive, make sure that the expansions are set to install in the same location.
avatar
invalidusername
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : The Sims, Assassin's Creed (All), Elder Scolls, Dragon Age : Origins, Harvest Moon, Mario, Zelda, Psychonauts, SimCity, House of the Dead : Overkill, Magic: The Gathering, Saint's Row, Civilization 5, The Witcher
Female Posts : 2043
Points : 4567
Reputation : 219
Join date : 2011-10-20
Age : 24
Location : Michigan

View user profile

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by austeyre on Tue 09 Oct 2012, 08:07

It installed to the default spot, so far as I know.
That is to say, I didn't specify anywhere else for it to install to?
It's in program files on the local disk, under Electronic Arts, which I assume is the default spot?

austeyre
Beginner
Beginner

Windows version :
  • Windows 7

Posts : 4
Points : 1845
Reputation : 0
Join date : 2012-10-09
Age : 24
Location : Canada

View user profile http://uss-assbutt.tumblr.com

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by nader704 on Tue 09 Oct 2012, 09:29

Hello

I have the same exact problem except i didnt download the base game i bought it from store...but yes tried installing pets and supernatural and same error poped up

nader704
Beginner
Beginner

Posts : 7
Points : 1852
Reputation : 0
Join date : 2012-10-05

View user profile

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by ☠ ~ Aɳɳ ~ ☠ on Tue 09 Oct 2012, 10:45

Hello,

Where did you get the base game?


nader704 wrote:Hello

I have the same exact problem except i didnt download the base game i bought it from store...but yes tried installing pets and supernatural and same error poped up

Please open a new topic. It'll be easier for us to keep track, and to provide more personal support.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20091
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by nader704 on Tue 09 Oct 2012, 11:02

Hmmmm well i did open a *new topic* and still no body gave me a solutiion :s

You asked me the exact question and i even uploaded pictures....

EDIT:

FINALY!!!i found a way to make it work!!!!Oki what i did was:

1.Uninstall sims 3 and delete any related files.

2.Open regedit search sims 3 and delete it

3.Open ccleaner (google and download it if you dont have it) and then click registry and find/fix all issues

4.reinstall sims 3 update it manually restart your pc

5.After restarting open sims 3 make sure you load till family and check if everything running smoothly

6.When your done checking close it and install the exp! : )

nader704
Beginner
Beginner

Posts : 7
Points : 1852
Reputation : 0
Join date : 2012-10-05

View user profile

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by austeyre on Tue 09 Oct 2012, 18:52

Thanks for the advice, love, but I use ccleaner quite regularly, including after this particular uninstall. Sadly, it didn't seem to make much of a difference. Glad it worked for you, though.

Sorry, I should have mentioned, all the downloads I'm using are from here.
I'd had a different version installed before, but it wasn't running to my satisfaction and I figured I might as well start fresh.

Actually, on a related note, I do still have some saved games from that old version.

I am in the process of downloading a manual patch for the game to see if that will help, but any other advice would be very much appreciated.

//EDIT

Update: Patching the game did not help, I still receive the same message when attempting to install an expansion pack.
Also,
now the game itself will not start, telling me that "there was an error
during startup. Please see the Log for more details".

austeyre
Beginner
Beginner

Windows version :
  • Windows 7

Posts : 4
Points : 1845
Reputation : 0
Join date : 2012-10-09
Age : 24
Location : Canada

View user profile http://uss-assbutt.tumblr.com

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by Adwomin on Tue 09 Oct 2012, 21:45

Hello,

Try Your Uninstaller! Pro - www.games4theworld.org - for uninstalling, please. Choose "Extreme" mode and restart your PC afterwards.

//EDITTry this, please: http://games4theworld.bestgoo.com/t6052-error-during-startup-see-log-for-more-details-fix
Read/watch very carefully.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026425
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by austeyre on Tue 09 Oct 2012, 23:22

I think I'm going through the gambit of possible errors with the base game, all the while still getting that original error when trying to install expansions.

I'm now being asked for the registration code when I attempt to play the base game, and although it pops up with one filled in, it won't accept it.

I am about 90% sure I saw other topics about this in the forum, so I will go browse there for a while, but if you have any specific advice for me that would be lovely. <3

EDIT:
The issue this time, if I read correctly, seems to be that I updated the game, so I shall completely reinstall and see what happens. Also clearing out the registry, and removing my saved games (as much as it pains me to do so) on the off-chance that they are causing some of the problems.

//EDIT

FIXED, I think.
So apparently the issue all along was that I still had things left in the registry from the previous version of the game and it was messing everything up.
At any rate, I'm currently installing the Pets expansion and it hasn't freaked out at me yet.
Thank you for your help! <3

austeyre
Beginner
Beginner

Windows version :
  • Windows 7

Posts : 4
Points : 1845
Reputation : 0
Join date : 2012-10-09
Age : 24
Location : Canada

View user profile http://uss-assbutt.tumblr.com

Back to top Go down

Re: Expansion pack installer does not recognize installed base game

Post by ☠ ~ Aɳɳ ~ ☠ on Wed 10 Oct 2012, 09:37

Hello,

Hopefully you didn't delete your savegames or can still salvage them, they don't usually cause problems with the entire game. They can be bugged but that just means that 1 save game is bugged or won't load at all.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20091
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum