"It requires..." problem. Sims 3 EP

View previous topic View next topic Go down

"It requires..." problem. Sims 3 EP

Post by TCPCohen on Thu 18 Oct 2012, 14:43

Hello everyone,
I've been reading all posts here but I can't find a similar one with the problem I'm having with the Sims 3 EP. I installed them all in chronological order (don't know if this matters or not, but I did it this way just in case) and now it shows this (see attached screen shot) in the Launcher.
It says that I only have the 4 last ones. Question

Well, I can't attach the pic because I exceeded total storage space (?)


Last edited by TCPCohen on Thu 18 Oct 2012, 14:46; edited 1 time in total (Reason for editing : Trouble attaching screen shot)
avatar
TCPCohen
Posting Lord
Posting Lord

Favourite games : Sims 3
Male Posts : 202
Points : 2072
Reputation : 13
Join date : 2012-10-17
Age : 32
Location : Spain

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by ☠ ~ Aɳɳ ~ ☠ on Thu 18 Oct 2012, 14:53

Hello,

Did you use the fix (for Mac)?

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by TCPCohen on Thu 18 Oct 2012, 14:54

Hello Smile
Yes, I did. And I put the crack into the Sims 3 base game and open the mini-image of Supernatural, which was the last one I installed. (Sorry about my English).
Thanks for your quick response
avatar
TCPCohen
Posting Lord
Posting Lord

Favourite games : Sims 3
Male Posts : 202
Points : 2072
Reputation : 13
Join date : 2012-10-17
Age : 32
Location : Spain

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by ☠ ~ Aɳɳ ~ ☠ on Thu 18 Oct 2012, 15:22

Hello,

I'm afraid I'm not the Mac-expert here. But lets see, try the manual patch, even if you're already at that game version. You may have to redo the crack afterwards.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by TCPCohen on Thu 18 Oct 2012, 15:30

I think I've already done this at the beginning of the installation, but how do I do this now?
I mean, it's not the 1.39 version anymore.
avatar
TCPCohen
Posting Lord
Posting Lord

Favourite games : Sims 3
Male Posts : 202
Points : 2072
Reputation : 13
Join date : 2012-10-17
Age : 32
Location : Spain

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by ☠ ~ Aɳɳ ~ ☠ on Thu 18 Oct 2012, 15:38

Hello,

It can fix some bugs if done again. You are still at game version 1.39, it's the latest version. You will probably receive a note that you're already at that patch level, but that can be ignored.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by Dieneryn on Thu 18 Oct 2012, 16:36

Hey there!
I have a few questions here:

1) Are all of your EPs downloaded from games4theworld?
2) If yes, did you extract them with Stuffit Expander before converting to .dmg?
3) Are you updated to v1.39?
4) Did you use the latest version of Ultimate Fix?

Here is how to check your base game version:
- Go to Applications> Right-click on The Sims 3 > Show Package Contents
- Press spacebar to preview 'info.plist'
- Scroll until you see ClientBuild (it will show the version there)

Cheers!
avatar
Dieneryn
Posting Master
Posting Master

Favourite games : The Sims Series, Harvest Moon Series, Legend of Zelda, Patapon, Ultimate Marvel vs Capcom, Pheonix Wright Series, Mario, and several other MMORPGs
Female Posts : 592
Points : 2597
Reputation : 86
Join date : 2012-09-09
Age : 27
Location : Woodland Realm, Mirkwood

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by TCPCohen on Thu 18 Oct 2012, 18:01

Hey, dieneryn!

1) Yes, the are, except the base game which I got it on the Razor version already from another site.
2) I extracted them with WinZip because the Stuffit expander won't do anything, it starts extracting them but when in the end nothing happens. (?) And I didn't convert them into .dmg. I have Daemon tools to open the .iso (maybe this is wrong).
3) Yes, I updated the base game before installing the first expansion (World adventures).
4) And yes, I did.

It says: "ClientBuild - 1.39.3.018002"

Thank you for your responses.

//EDIT

Oh! I've just opened the Uninstaller app and it only gives the option to
uninstall base game, Showtime, Katy Perrys, Diesel and Supernatural
when I have them ALL installed.
How can this be possible?
avatar
TCPCohen
Posting Lord
Posting Lord

Favourite games : Sims 3
Male Posts : 202
Points : 2072
Reputation : 13
Join date : 2012-10-17
Age : 32
Location : Spain

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by Dieneryn on Fri 19 Oct 2012, 01:37

Hi there!

You probably can't uninstall because they weren't installed properly.

Here's what you have to do with the EPs downloaded from games4theworld.

1) Unzip them using Stuffit Expander so that it creates a folder with the files. (The reason is that Stuffit Expander is the ONLY expander known so far that fully unzip the files)

2) Check the file size of the upzipped folder. (Eg. Ambitions - 4.97 GB)

3) We will now create the .dmg file. To do this, open up ‘Disk Utility’ from the ‘Applications’
folder. Select ‘New Image’ from the Disk Utility.

Save As: (anything you wish to call it)
Name: (anything you wish to call it)
Size: at least 0.1 GB larger than the file size noted in Step 2. (Eg. 5.1GB)
Partitions: CD/DVD

Click “Create”.

4) Open up the dmg you just created. You will realise that its empty. Copy all the contents (cmd+a to select all files) of your unzipped folder into the .dmg image.

The EP will now be ready to install! You have to do this for all the EPs (:
avatar
Dieneryn
Posting Master
Posting Master

Favourite games : The Sims Series, Harvest Moon Series, Legend of Zelda, Patapon, Ultimate Marvel vs Capcom, Pheonix Wright Series, Mario, and several other MMORPGs
Female Posts : 592
Points : 2597
Reputation : 86
Join date : 2012-09-09
Age : 27
Location : Woodland Realm, Mirkwood

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by TCPCohen on Fri 19 Oct 2012, 11:41

Hello again! Smile

The thing is... I can't uninstall them because they aren't there BUT when I click on install, it says if I'm sure I want to overwrite that Expansion because I already have it. (?) It's hilarious! Very Happy

Ok, then. I guess I'll have to download everything again because I deleted the .RAR and only have the .iso thing.
Stuffit hasn't been working for me but I'll try again.

Regarding the .dmg file, mind me asking, why do I need to do that? I mount the .iso with Disk Utility and it went fine, because installing with Daemon Tools caused some of the EPs to crash at the final step of the installation.

I'm going to do everything you say and I'll tell you after done.
Thank you VERY much for your help. <3
avatar
TCPCohen
Posting Lord
Posting Lord

Favourite games : Sims 3
Male Posts : 202
Points : 2072
Reputation : 13
Join date : 2012-10-17
Age : 32
Location : Spain

View user profile

Back to top Go down

Re: "It requires..." problem. Sims 3 EP

Post by Dieneryn on Fri 19 Oct 2012, 18:09

Hey there! Make sure you delete everything before reinstalling!

- Try the uninstaller. If it does not work, delete all the sims 3 files found in Applications.
- Follow this to remove all other files: https://help.ea.com/article/how-to-uninstall-the-sims-3-on-a-mac
- Make sure "Electronic Arts" folder found in Documents is also deleted.

Empty your trash!

Do keep us updated on your progress (=
avatar
Dieneryn
Posting Master
Posting Master

Favourite games : The Sims Series, Harvest Moon Series, Legend of Zelda, Patapon, Ultimate Marvel vs Capcom, Pheonix Wright Series, Mario, and several other MMORPGs
Female Posts : 592
Points : 2597
Reputation : 86
Join date : 2012-09-09
Age : 27
Location : Woodland Realm, Mirkwood

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum