Mass Effect 1 crash/problems/question. [SOLVED]

View previous topic View next topic Go down

Mass Effect 1 crash/problems/question. [SOLVED]

Post by AxeX on Sat Feb 19, 2011 2:10 am

EDIT: This problem of mine has (for now) been solved! For anyone having crashes with this game and can't figure out the problem, even if its the dreaded nv4_disp error, and you have alt-tabbed the game, try not too! Not doing so has eliminated the crashes for me so far, and it could work for you!


Alright, so I've downloaded this game twice so far in hopes my problem will go away. So far no luck on my end, maybe someone here has an answer for me.

Straight up, my main issue is my game crashing with the dreadful nv4_disp message. Before doing an extensive testing and updating/reinstallation, the game usually crashed every 10 or so minutes, but I just played it for several hours afterwards before crashing. But it still crashes so I'm now confused as to what the problem is.

Specs:
Windows XP Pro SP 3
Nvidia GeForce 9800 GT 1GB
Intel Pentium D 3.20 GHz
4x 1GB Dual-Channel DDR2 @ 266 MHz RAM chips
400W Delta Electronics INC PSU

As I said, I did extensive testing. I reinstalled the game several times (to make sure it just wasn't a corrupt install), I checked to see my PSU was giving enough power. I uninstalled EVERYTHING with even a hint of Nvidia on it, did several passes with a driver sweeper, and then did a clean install of the latest drivers. I even did the process over again with some of the recent, but older drivers. I also stress tested the GPU, CPU, and the RAM for 5 hours using furmark and prime95, nothing went above 90 celsius and no errors popped up during these tests. Lastly, I then checked the Graphics cards clocking speeds, one of the speeds is stock while the others are underclocked.

As you can see, I left no stone unturned (at least the ones I saw). If there was a problem, it would of shown itself during the testing. The only thing I did not test was recreating the problem in game using different hardware, as I do not have the extra parts nor the cash to get them.

I have downloaded and installed this game twice, the first time not really reading the instructions and following them to the letter, but the second time I did. I used both the detailed instructions in the .rar and the instructions the uploader gave on thepiratebay.

I dragged and dropped all files (except for the support files) onto my desktop using Winrar as instructed. I installed, using one of the keycodes provided. I then copied the mapfix .EXE over. I also ran the config and changed some settings before booting up the game and making sure it runs. No problems so far.

Being a person that hates bugs and glitches with a passion, I wanted to patch, and so I followed the instructions on TPB and downloaded the patch and the crack the uploader linked too. I patched the game like normal, and then used Winrar again to pull out the crack *ONLY* and copy it into the binaries folder. I then go to run the game and.... BAM. "Mass Effect has encountered a problem and needs to close." But wait! Why did it work the first time?! Because I didn't listen to directions and copied EVERYTHING from the crack .rar over, this includes the the "rld.dll" and the "rld.bin" files that the uploader said NOT to copy over.

So I tried it again, copied the two files over and tried running the game, and VIOLA it works. I then went back to the games .rar, and searched at length for these two files, thinking they might of not gotten installed or copied over when I unzipped it, and that the crack's version was causing a conflict. Nope, nothing, not a single trace of these two files.

I'm going to assume that these two files are the reason I'm both able to play and having these crashes. What do ya'll think?


Last edited by AxeX on Sun Feb 20, 2011 2:41 pm; edited 1 time in total

AxeX
Beginner
Beginner

Posts : 3
Points : 2381
Reputation : 0
Join date : 2011-02-19

View user profile

Back to top Go down

Re: Mass Effect 1 crash/problems/question. [SOLVED]

Post by Adwomin on Sat Feb 19, 2011 10:15 am

Hello,

Yes, we're aware of these sudden Mass Effect problems and the thing is that we're still experimenting with it, so we can see what could fix these problems. (Which look all similar to each other)

Now, please try as following:

*Backup your savegames

1. Completely uninstall the game.
2. Restart your PC.
3. Open the .rar file you downloaded using only WinRar, which can be downloaded from www.games4theworld.org . (If you use any other software than WinRar, like WinZip or 7-zip, the files will get messed up!)
When you've opened the file using WinRar, select áll the files (So don't skip anything!) in it and drag & drop them to a folder on your Desktop. When the extraction is done, close the .rar file and open the folder on your Desktop.

4. Install the game and apply the Map Fix.
5. Patch your game to the latest version like you did before. (So apply áll files / cracks)
6. When that is done, go to the Game's Directory (C:\Program Files (x86)\Mass Effect\Binaries) and run the "MassEffect.exe" as an Admin. (Right-click on it and choose "Run as Admin")
7. See if it works now.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026351
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 crash/problems/question. [SOLVED]

Post by AxeX on Sat Feb 19, 2011 1:56 pm

Alright I did, but it still won't run without the rld.dll and rld.bin files from the patch crack that I'm supposedly not supposed to copy over.

I was playing in windowed mode earlier and wasn't having any problems, hopefully when I get back later it won't crash when I try to play fullscreen.

EDIT: Also, I must ask, is there anything of absolute importance in the support folder of the .rar?

AxeX
Beginner
Beginner

Posts : 3
Points : 2381
Reputation : 0
Join date : 2011-02-19

View user profile

Back to top Go down

Re: Mass Effect 1 crash/problems/question. [SOLVED]

Post by Adwomin on Sat Feb 19, 2011 2:14 pm

@AxeX wrote:Alright I did, but it still won't run without the rld.dll and rld.bin files from the patch crack that I'm supposedly not supposed to copy over.

I was playing in windowed mode earlier and wasn't having any problems, hopefully when I get back later it won't crash when I try to play fullscreen.

EDIT: Also, I must ask, is there anything of absolute importance in the support folder of the .rar?
Hello,

Well, also apply the rld.dll and rld.bin.
I'm not sure about the "support" folders, but you never know. You should always copy éverything for best performance.
See if it works in Full Screen now. (Remember: Run as Admin)

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026351
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 crash/problems/question. [SOLVED]

Post by AxeX on Sun Feb 20, 2011 2:41 pm

Alright so I've decided to just leave the rld thing alone. I've also decided to just keep forgoing the support folders from the original .rar, as they've not been whats causing my crashes so far, and I still trust my antivirus programs over ya'll (they haven't let me down yet!).

After extensive playtesting, the only logical conclusion I can come to is that something about the game itself (whether torrented or bought) has an issue with being alt-tabbed, as because of my recent playtime I've only alt-tabbed twice and both times it crashed, but when I didn't, it didn't crash. When I first started playing with this torrent however, I treated it like most games, thinking it'd be fine to alt-tab, so I did it numerous times.

So I guess the moral of this story is, the biggest problems can sometimes be of the simpliest nature, making it hard to detect and resolve.

I'll be editing my OP to put my solution in, in case it might help others. Go ahead and lock and tag this thread as solved. I'll let ya'll know if I have anymore problems. Thanks for helping me troubleshoot!

Admin edit: Ok, great! Have fun playing for now! Problem solved, topic closed.

- ADMIN

AxeX
Beginner
Beginner

Posts : 3
Points : 2381
Reputation : 0
Join date : 2011-02-19

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum