Endless Lagging.[SOLVED]

View previous topic View next topic Go down

Endless Lagging.[SOLVED]

Post by anatollie on Thu 10 Jan 2013, 03:27

Okay, so I have the good old lag/freeze with animations still running issue since I came into possession of this game. Absolutely nothing seems to work. I wonder if I will ever be able to actually play the game properly, never having seen it run smoothly. I own the base game with Generations, Late Night, World Adventures, Seasons, Pets, and Ambitions. I don't use the latter two because they seemed to amp up the lag to a whole new level of unplayable.

Hopefully you guys and gals can shed some light on the matter; I came here because I found this forum to be the most comprehensive. Smile

My specifications are as follows:
Windows 7 Professional (64 bit)
Intel Core i7 3820 CPU (3.60GHz)
16gb RAM
NVIDIA GeForce GTX 460

(Note: I have used four other computers before this one, and suffered the same issue.)

In the way of CC, I only use the NRaas modifications mentioned below, and would like to use Story Progression. I prefer to play with legacy mode so this is necessary if I don't want to waste time manually 'breeding' NPCs. Story Progression appears to make the lag even worse.

And here is what I have attempted so far in the way of troubleshooting:
-Used the tool to allow TS3 to use 4gb of RAM, and modified the allowed amount in the appropriate .ini file.
-Performed a clean install with the manual (non-launcher) patch, and ran the game with no CC.
-Used NRaas overwatch/master controller to do a regular clean-up of stuck cars, stuck NPCs, and whatever else.
-Deleted my cache files.
-Installed all the neighborhood routing fixes from MTS3. ALL neighborhoods still suffer from this crippling lag.
-Cried softly in a corner.
-Followed instructions from Origin support (clean out Windows/Temp files).
-Docked the graphics settings down to absolute minimum.
-Prudently updated video card drivers several times over the course of the year.
-resetSim *, resetSim *, resetSim *, and then eventually force-killed the problem Sim with NRaas tools.

Any further suggestions would be much appreciated.

anatollie
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Crusader Kings II, The Witcher, Arcanum, Avernum, Mount & Blade: Warband
Female Posts : 6
Points : 1689
Reputation : 0
Join date : 2013-01-10
Location : Grønland

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by Aɾყα on Thu 10 Jan 2013, 11:02

Hello,

It seems like you have already tried a whole lot. But lets see what else we can try, because to me it sounds ridiculous that you can't play without lag. I'm on a single core 1 GB 7600GS pc with XP and I can play without serious amounts of lag. And I do also have Story Progression and a number of other Nraas mods. On medium graphics settings. With more EP's than you're using (WA, AMB, GEN, Pets, Seasons), and almost 500 sims3packs installed.
So I'm baffled when I see someone who has a pc that is obviously much more powerful than mine suffering problems I'm not. It almost makes me reluctant to upgrade to a better PC.

Lets see..
Turn off your antivirus, your torrent client (if you use one). Better yet, try Gamebooster. It'll turn off all unneeded background processes, although AV and torrent clients are the worst.

Do you have a population cap? Nraas story progression caps population at 150 by default, it should still be so unless you changed it. How much do you push sims around town with Nraas SP?

Do you have any user created worlds? Are they as bad? Huge worlds or small?

Do you keep all tombstones (another Nraas SP setting)?

In the in game graphics settings, do you have reflections on? How is the draw distance set? How many high detail lots?

Are you allowing memory creation? Retain dreams and opportunites for NPC's?

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20012
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by anatollie on Fri 11 Jan 2013, 08:43

Let's see...

I don't have AV or a torrent client, so that's not going to be an issue. I'm pretty finicky about what items are allowed to operate when I first boot in to Windows. The only applications that run at start time are: Realtek Audio Manager, Steam, and some thing for my printer.

I don't really 'use' SP. It's only there to keep my town populated. So none of the settings are tweaked, aside from turning 'stories' off. Defaults should still be in place. I'm not sure about the tombstone thing, but I'll try to toggle that if it's on.

Only default worlds are used in game.

I have turned reflections off, and all of the other graphical settings are set to blob.

Yesterday I put in a mod to limit memories. It removes all of the low-key stuff (went to the park, petted a cat). I'll check if the NPCs are allowed to have memories and dreams too.

Thank you for your assistance. I'll report back shortly!

EDIT: Turned all memories off. Tombstones are not kept, and the population limit is at 150. Still hitting the intermittent freezes. Sad

anatollie
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Crusader Kings II, The Witcher, Arcanum, Avernum, Mount & Blade: Warband
Female Posts : 6
Points : 1689
Reputation : 0
Join date : 2013-01-10
Location : Grønland

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by Aɾყα on Fri 11 Jan 2013, 10:08

Hello,

Try tweaking storyprogression a little more, you don't need a lot of the default options and they might add to lag.
Which other mods are you using?

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20012
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by anatollie on Fri 11 Jan 2013, 10:45

From NRaas: SP, Overwatch, Master Controller, ErrorTrap, Woohooer, Register.
And then the mod that removes memories entirely.
Absolutely nothing else.

anatollie
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Crusader Kings II, The Witcher, Arcanum, Avernum, Mount & Blade: Warband
Female Posts : 6
Points : 1689
Reputation : 0
Join date : 2013-01-10
Location : Grønland

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by Aɾყα on Fri 11 Jan 2013, 13:32

Hello,

Where did you install?
The default directory or a different drive?

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20012
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by anatollie on Fri 11 Jan 2013, 23:06

Default Steam directory, and then default Origin directory.

I have tweaked a lot of things with Master Controller and I am still seeing no difference. Also tried running the game in Windowed mode so I could watch system resources. It's taking up 30% of the CPU power, maximum.

Perhaps I should try a custom neighbourhood. The routing might be better on one of them. What is a good basic one? Or something similar to Bridgeport with the apartments?

anatollie
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Crusader Kings II, The Witcher, Arcanum, Avernum, Mount & Blade: Warband
Female Posts : 6
Points : 1689
Reputation : 0
Join date : 2013-01-10
Location : Grønland

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by Aɾყα on Sat 12 Jan 2013, 11:42

Hello,

I don't know about a good custom world, I never found what I was looking for so I never bothered much, but you can find lots of worlds on modthesims for example.

How do you feel about trying an FPS limiter? The Sims 3 is known for going wacky with the framerate. You could test if this is true by showing the fps rate on your screen during game play. You can use the cheat code fps on to activate this function. If it varies a lot, that could explain (some of) it as well.


_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20012
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by anatollie on Sat 12 Jan 2013, 12:03

Much to my surprise, using a non-default world results in absolutely smooth game-play. However, it's not populated. Is there a function to generate NPCs in one of the NRaas modifications?

I'll give a default neighbourhood one more shot with an FPS limiter as well. Thanks for the suggestion. Smile

anatollie
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Crusader Kings II, The Witcher, Arcanum, Avernum, Mount & Blade: Warband
Female Posts : 6
Points : 1689
Reputation : 0
Join date : 2013-01-10
Location : Grønland

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by Aɾყα on Sat 12 Jan 2013, 12:26

Hello,

Story progression will populate the world over time. But you can also choose to use Porter to pack up an existing neighbourhood's residents to populate your world. All relationships will remain intact.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20012
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by invalidusername on Sat 12 Jan 2013, 18:50

A quick question, though you seem to have basically solved this, was the lag only occurring in Bridgeport? If so, it's actually easily explained away. Bridgeport is terrible for sims getting stuck and being pushed out around town too much. The subways cause issues, and I guess the food truck does too.
avatar
invalidusername
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : The Sims, Assassin's Creed (All), Elder Scolls, Dragon Age : Origins, Harvest Moon, Mario, Zelda, Psychonauts, SimCity, House of the Dead : Overkill, Magic: The Gathering, Saint's Row, Civilization 5, The Witcher
Female Posts : 2043
Points : 4502
Reputation : 219
Join date : 2011-10-20
Age : 24
Location : Michigan

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by anatollie on Sun 13 Jan 2013, 05:51

All default neighborhoods were subject to extreme lag and intermittent freezing.

I have populated the custom world fully by now. It's bigger than Bridgeport (city and suburban areas), and has absolutely no issues.

It really doesn't make any sense. I guess that mystery will never be solved.

anatollie
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Crusader Kings II, The Witcher, Arcanum, Avernum, Mount & Blade: Warband
Female Posts : 6
Points : 1689
Reputation : 0
Join date : 2013-01-10
Location : Grønland

View user profile

Back to top Go down

Re: Endless Lagging.[SOLVED]

Post by Aɾყα on Sun 13 Jan 2013, 09:40

Hello,

Probably routing issues, even with the MTS routing fixes. I think custom world creators are more careful about the routing in their worlds.
At least your problem is, more or less, solved.
Don't hesitate to post if you have questions or problems again.
Happy simming The Sims Plumbob 1 topic closed.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20012
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum